CVE-2021-39197

Published 10 days ago
Category: Cross-Site Request Forgery
Source: GitHub
Severity: Moderate

Vulnerability in better_errors

Impact

better_errors prior to 2.8.0 did not implement CSRF protection for its internal requests. It also did not enforce the correct “Content-Type” header for these requests, which allowed a cross-origin “simple request” to be made without CORS protection. These together left an application with better_errors enabled open to cross-origin attacks.

As a developer tool, better_errors documentation strongly recommends addition only to the development bundle group, so this vulnerability should only affect development environments. Please ensure that your project limits better_errors to the development group (or the non-Rails equivalent).

Patches

Starting with release 2.8.x, CSRF protection is enforced. It is recommended that you upgrade to the latest release, or minimally to “~> 2.8.3”.

Workarounds

There are no known workarounds to mitigate the risk of using older releases of better_errors.

References

For more information

If you have any questions or comments about this advisory, please - Add to the discussion in better_errors - Open an issue in better_errors

CVSS Metrics
Access Vector Access Complexity Authentication Confidentiality Impact Integrity Impact Availability Impact
n/a n/a n/a n/a n/a n/a
Patched Versions

>= 2.8.0

Unaffected Versions

n/a

References

n/a