CVE-2019-10842

Published 2 months ago
Category: Code Injection
Source: GitHub
Severity: Critical

Vulnerability in bootstrap-sass

Arbitrary code execution (via backdoor code, when downloaded from rubygems.org) was discovered in bootstrap-sass 3.2.0.3.

Users are advised to upgrade immediately to 3.2.0.4

An unauthenticated attacker can craft the ___cfduid cookie value with base64 arbitrary code to be executed via eval(), which can be leveraged to execute arbitrary code on the target system. (Note that there are three underscore characters in the cookie name. This is unrelated to the __cfduid cookie that is legitimately used by Cloudflare.)

CVSS Metrics
Access Vector Access Complexity Authentication Confidentiality Impact Integrity Impact Availability Impact
n/a n/a n/a n/a n/a n/a
Patched Versions

>= 3.2.0.4

Unaffected Versions

<= 3.2.0.2

References

n/a