CVE-2021-23435

Published 4 days ago
Category: Session Setting
Source: GitHub
Severity: Moderate

Vulnerability in clearance

This affects the package clearance before 2.5.0. The vulnerability can be possible when users are able to set the value of session[:return_to]. If the value used for return_to contains multiple leading slashes (/////example.com) the user ends up being redirected to the external domain that comes after the slashes (http://example.com).

CVSS Metrics
Access Vector Access Complexity Authentication Confidentiality Impact Integrity Impact Availability Impact
n/a n/a n/a n/a n/a n/a
Patched Versions

>= 2.5.0

Unaffected Versions

n/a

References

n/a