CVE-2020-15240

Published 30 days ago
Category: Authentication
Source: GitHub
Severity: Critical

Vulnerability in omniauth-auth0

Overview

Versions after and including 2.3.0 are improperly validating the JWT token signature when using the JWTValidator.verify method. Improper validation of the JWT token signature when not using the default Authorization Code Flow can allow an attacker to bypass authentication and authorization.

Am I affected?

You are affected by this vulnerability if all of the following conditions apply:

  • You are using omniauth-auth0.
  • You are using JWTValidator.verify method directly OR you are not authenticating using the SDK’s default Authorization Code Flow.

How to fix that?

Upgrade to version 2.4.1.

Will this update impact my users?

The fix provided in this version will not affect your users.

CVSS Metrics
Access Vector Access Complexity Authentication Confidentiality Impact Integrity Impact Availability Impact
n/a n/a n/a n/a n/a n/a
Patched Versions

>= 2.4.1

Unaffected Versions

< 2.3.0

References

n/a