CVE-2011-2932

Published almost 9 years ago
Category: Cross-Site Scripting
Source: NIST NVD
Severity: Moderate

Vulnerability in rails

Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails 2.x before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows remote attackers to inject arbitrary web script or HTML via a malformed Unicode string, related to a “UTF-8 escaping vulnerability.”

CVSS Metrics
Access Vector Access Complexity Authentication Confidentiality Impact Integrity Impact Availability Impact
Network Medium None None Partial None
Patched Versions

n/a

Unaffected Versions

n/a